帮酷LOGO
1 0 评论
文章标签:SUP  Discourse  disco  

为什么不支持它,Discourse公告说它太老旧,但是,MySQL 目前仍然是最流行的数据库之一。

主要的原因是搜索,PostgreSQL拥有更好的全文搜索功能。

还有关于使用Oracle拥有MySQL的许可的问题。

MySQL缺少Discourse想要的特性,并且多数据库开发显著增加了编码,调试,测试,性能调优和维护的时间,大多数社区也采用了PostgreSQL,因此一旦选择了语言和平台,数据库就自然而然选择了PostgreSQL。

但是,作为开源项目,你可以自由地把它改成适应MySQL,我知道很多开发人员都愿意这样做,如果你不能做到这一点,那么只要等一年,别人就会为你做到。

由于上面给出的原因,它不可能很快得到核心开发者的支持,因为有大量的功能列表有更高的优先级。



文章标签:SUP  disco  Discourse  

Copyright © 2011 HelpLib All rights reserved.    知识分享协议 京ICP备05059198号-3  |  如果智培  |  酷兔英语